Delay on billing information
Incident Report for Fairhair.ai
Resolved
Billing services are now functioning as normal.
Posted 28 days ago. Nov 13, 2018 - 10:45 UTC
Identified
A critical issue has been identified and resolved in our billing information collection infrastructure. The collection process was paused for safety. A fix has been released and we are now processing a backlog of billing events.
Posted 28 days ago. Nov 12, 2018 - 20:34 UTC
Investigating
Updates to billing information including account balances are currently delayed.
Posted 29 days ago. Nov 12, 2018 - 14:42 UTC
This incident affected: User Interface and API.