Emergency maintenance: Delay on billing information
Incident Report for Fairhair.ai
Resolved
This incident has been resolved.
Posted 3 months ago. Sep 24, 2018 - 12:59 UTC
Identified
Updates to billing information including account balances are currently delayed.
Posted 3 months ago. Sep 24, 2018 - 10:36 UTC
This incident affected: User Interface and API.