Delays on delivery to Push Destinations
Incident Report for Fairhair.ai
Resolved
This incident has been resolved.
Posted Nov 19, 2019 - 19:35 UTC
Investigating
We are observing increased latency on deliveries to Push Destinations. We are working to resolve this.
Posted Nov 19, 2019 - 19:17 UTC